Battery died after upgrades. - Range Rover Velar Forum
 1Likes
  • 1 Post By Laptopt
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 07-21-2019, 11:12 AM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 6
Battery died after upgrades.

I just had Apple Car Play installed on my 2018 P380 SE R Dynamic in order to prepare for our family vacation.
I had the car back for 2-1/2 days before my wife and I would take a mini vaca and be gone for a week. The Velar stayed in the garage and when I returned to take it out for a spin, the battery was completely dead.
I jumped it with my truck and let it run for a bit prior to taking it out. While backing it up, multiple issues with power steering and some flashing on the dash.
I didn’t think too much of it and wanted to take it around the subdivision. After 1/4 mile, multiple lights started to flash, jerking in the car, power steering failing, and I tried to loop back to my house. Didn’t quite make it.
Called RR Roadside and had to have the car towed to the dealer. Complete system failure is what I’m being told. Crashed the computer.
Needless to say, I leave for family vacation in five days and my wife isn’t thrilled with taking this car on a 900 mile trek.
Anyone else heard of this issue? Could this be related to the infotainment/Car Play upgrade? Why the dead battery after one week? Only 12,600 miles on this beautiful car that is now leaving a very sour taste in my mouth.
Laptopt is offline  
post #2 of 6 (permalink) Old 07-24-2019, 07:49 PM
Junior Member
 
Join Date: Oct 2018
Location: United States - Northeast
Posts: 11
Garage
Hi. I have a 2018 RR Velar P380 HSE and I too had the same problem my battery dying and a complete system failure. I cannot say it had anything to do with a software update but the battery completely died and was replaced by my local Land Rover dealership. They actually brought me a loaner to my home and then returned my car and picked up the loaner. Great service I must say.

I have not had any issues ever since but electronics were flaky to say the least. In any case Iíd really love to find out what was the actual cause of this happening. Anyone else?

Cheers! 👍
KKT-Velar
KKT-Velar is offline  
post #3 of 6 (permalink) Old 07-24-2019, 08:42 PM
Member
 
Join Date: May 2018
Posts: 44
Garage
Quote:
Originally Posted by Laptopt View Post
I just had Apple Car Play installed on my 2018 P380 SE R Dynamic in order to prepare for our family vacation.
I had the car back for 2-1/2 days before my wife and I would take a mini vaca and be gone for a week. The Velar stayed in the garage and when I returned to take it out for a spin, the battery was completely dead.
I jumped it with my truck and let it run for a bit prior to taking it out. While backing it up, multiple issues with power steering and some flashing on the dash.
I didnít think too much of it and wanted to take it around the subdivision. After 1/4 mile, multiple lights started to flash, jerking in the car, power steering failing, and I tried to loop back to my house. Didnít quite make it.
Called RR Roadside and had to have the car towed to the dealer. Complete system failure is what Iím being told. Crashed the computer.
Needless to say, I leave for family vacation in five days and my wife isnít thrilled with taking this car on a 900 mile trek.
Anyone else heard of this issue? Could this be related to the infotainment/Car Play upgrade? Why the dead battery after one week? Only 12,600 miles on this beautiful car that is now leaving a very sour taste in my mouth.
Wow, that stinks! Hope they're able to get it sorted out in time for your vacation. It's a great vehicle on a long trip. Keep us posted. I'd love to learn what caused this problem.
NovaVelar is offline  
post #4 of 6 (permalink) Old 08-01-2019, 07:53 PM
Senior Member
 
Join Date: May 2017
Posts: 185
Hopefully issues like this will be better sorted out once JLR starts selling fully electric vehicles. Maybe its why we're not seeing their best in ICE vehicles.
audemar4play is offline  
post #5 of 6 (permalink) Old 08-07-2019, 11:05 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 6
Update on battery changeout. Sorry for the delay, but took the Velar on vaca and no issues with the vehicle.....only an issue with a Chevy truck hitting me on our way south. No injuries, fortunately, but will cost this guys plenty on insurance. Looks minor, but it is a Range Rover.
Averaged 24.5 mpg at 80 mph and Comfort mode on. Love the Velar.

I digress.....the battery was replaced. They renewed the Battery Monitoring System then found the Eco Stop/Start system was inoperative. Fixed that and also took care of the Quiescent Current Control Module and the Gateway Module. Whew. Mouthful.

They performed the multi-point inspection and got a Evaporative Leak Monitor Cause which required the Powertrain Control Module to be updated and replaced.

If anyone would like the numbers or codes referenced on my receipt, please let me know and I will copy it all.

Good luck!
audemar4play likes this.
Laptopt is offline  
post #6 of 6 (permalink) Old 08-22-2019, 02:30 AM
Senior Member
 
Join Date: May 2017
Posts: 185
Glad to see issues are being sorted out. Your reports and those of others will go a long way to ensure Velar ownership remains positive.
audemar4play is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome