Inside Cabin Temperature Too Hot - Range Rover Velar Forum
 1Likes
  • 1 Post By KKT-Velar
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 12-17-2018, 11:58 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: United States - Northeast
Posts: 11
Garage
Inside Cabin Temperature Too Hot

Yesterday I experienced some weird things going on with my climate control system. The outside temperature was 43 degree Fahrenheit, and my inside climate control system was set to 68. I don't have separate climate controls for the rear but the vents were blasting out hot air in the rear and cooler air up front. The only way to get cool air in the back was to turn on the AC and lower my climate control temperature to 62 degrees. As soon as I turn it up to 66 hot air was flowing once again in the rear.

I am also not thrilled with the air vents up front. They either blow air in your face or on my chest if I lower the vents. There is also no way to raise the vents to blow higher. Not impressed!

Is anyone else experiencing this? If not, perhaps another trip to the dealer may be required for service.

Cheers! 👍
KKT-Velar
KKT-Velar is offline  
post #2 of 4 (permalink) Old 12-17-2018, 01:50 PM
Senior Member
 
Join Date: May 2017
Posts: 184
I know this and/or similar issues with the AC/HVAC has happened with other Range Rover/Land Rover products. Initially you should check with the dealer for a possible Technical Service Bulletin (TSB)
audemar4play is offline  
post #3 of 4 (permalink) Old 12-17-2018, 08:40 PM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: United States - Northeast
Posts: 11
Garage
Thank you for your reply audemar4play. Interestingly enough this didn't happen tonight when I took the car out. It's a crap shoot with this car as things act up with no rhyme or reason at times and when you shut down the car and restart it later, it seems things go back to normal operating conditions. Go figure. If it does happen again I will make an appointment at my dealer to have it checked out. Thanks again.
audemar4play likes this.

Cheers! 👍
KKT-Velar
KKT-Velar is offline  
post #4 of 4 (permalink) Old 12-23-2018, 09:18 PM
Senior Member
 
Join Date: May 2017
Posts: 184
Quote:
Originally Posted by KKT-Velar View Post
Thank you for your reply audemar4play. Interestingly enough this didn't happen tonight when I took the car out. It's a crap shoot with this car as things act up with no rhyme or reason at times and when you shut down the car and restart it later, it seems things go back to normal operating conditions. Go figure. If it does happen again I will make an appointment at my dealer to have it checked out. Thanks again.
If you're lucky, sometimes dealers are willing to keep the vehicle for a few days to hopefully replicate the issue themselves. Persuading them to do that might be an option.
Or of course you can find ways to reproduce the issue yourself, most folks I know don't go to the dealer unless they can reproduce it.
audemar4play is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome